Beiträge

Meta Data Generator for Updating Modules to the New Structure

update OXID modules to the new structure - metadata.phpA while ago we announced that we would phase out the support for the formerly used modules coded for OXID eShop series < 4.7 (5.0). In order to put a little helpful tool in your hands we recently published the metadataGenerator extension for OXID eShop.

This extension is intended to generate the necessary file metadata.php in the module folder of latter shop versions according to the metadata protocol v1.1: all required parameters will be parsed.

Roll up your sleeves and get your legacy modules ready for OXID eShop series 4.9 (CE, PE) and 5.2 (EE)!

PHP 5.2 Will not be Supported from OXID eShop Versions 4.8 and 5.1 on

We will still publish OXID eShop Enterprise Edition version 5.1 and OXID eShop Professional and Community Edition version 4.8 during this autumn. We would like to mention that with this release, we will be dropping the support of PHP 5.2.

The end of support for PHP 5.2 was already earmarked in December 2010. This means that PHP version 5.2.16 is the last release in this series, and will not be developed any longer. In other words: PHP 5.2 is already three years old.

We’ll drop the support for PHP 5.2 in OXID eShop all editions in the following manner:

  • We will not test OXID eShop in a PHP 5.2 environment any more.
  • Our coding style is still 5.2 compatible. Therefore it will most likely still work with 5.2 setups. OXID eShop Enterprise Edition 5.1 & Professional and Community Edition 4.8, most likely still work properly with PHP 5.2: we have now stopped officially supporting it. Starting with the next major release of OXID eShop we will use PHP 5.3 language features.
  • We will stop the maintenance – this means fixing bugs – in OXID eShop and will not build workarounds related to PHP 5.2.
  • We will stop delivering Zend encoded versions for PHP 5.2. Instead we’ll deliver Zend encoded files for PHP 5.3 and PHP 5.4.

Before you update your PHP version please make sure that you possess OXID eShop Professional or Enterprise Edition with the correct files encoded for the new PHP version. In doubt, please turn to our support team. Please also make sure that the modules you use are encoded correctly for the new PHP version – otherwise please turn to the vendor of this module.

Please note that this change is not intended to generate more work nor to annoy anybody. Dropping the support for PHP 5.2 is a necessary step to avoid the vulnerability caused by using an outdated software environment. Also we would like to explore the myriad of possibilities of a more modern software development with PHP 5.3 and higher.